Why ZeFit is only compatible with Android 4.3 and above versions ?